Apache Druid任意文件读取漏洞细节及EXP公开,速查

2021-11-23 15:38:47 Author: www.freebuf.com 阅读量: 16 收藏

一、事件背景

近日,Apache Druid 任意文件读取漏洞细节及 EXP 在互联网公开,攻击者可通过将文件 URL 传递给 HTTP InputSource 来绕过应用程序级别的限制。由于 Apache Druid 默认情况下是缺乏授权认证,攻击者可构造恶意请求,在未授权情况下利用该漏洞读取系统任意文件,最终导致服务器敏感信息泄露。

此次受影响 Apache Druid 版本如下:

Apache  Druid版本是否受影响
Version < 0.22
Version >=0.22

二、漏洞概况

Apache Druid 是一个实时分析型数据库,旨在对大型数据集进行快速的查询分析。Druid 最常被当做数据库来用以支持实时摄取、高性能查询和高稳定运行的应用场景,也通常被用来助力分析型应用的图形化界面,或者当做需要快速聚合的高并发后端 API,Druid 最适合应用于面向事件类型的数据。

在 Apache Druid 系统中,InputSource 用于从某个数据源读取数据。由于没有对用户可控的 HTTP InputSource 做限制,Apache Druid 允许经过身份验证的用户以 Druid 服务器进程的权限从指定数据源读取数据,包括本地文件系统。

攻击者可通过将文件 URL 传递给 HTTP InputSource 来绕过应用程序级别的限制。由于 Apache Druid 默认情况下缺乏授权认证,攻击者可构造恶意请求,在未授权情况下利用该漏洞读取任意文件,最终导致服务器敏感信息泄露。

三、修复方案

安装 Apache Druid 的用户可根据受影响版本下载官方最新版本安装,安装前建议做好系统备份。

相关官方最新版本下载地址如下:

https://www.apache.org/dyn/closer.cgi?path=/druid/0.22.0/apache-druid-0.22.0-bin.tar.gz

四、检测工具

在对安装受影响 Apache Druid 版本的用户未能进行完全修复情况下,互联网已经公开了多个检测工具。

微步在线威胁感知平台 TDP 已支持该漏洞的检测。

相关工具参考链接如下:

https://github.com/dorkerdevil/CVE-2021-36749/blob/main/CVE-2021-36749.py

https://github.com/BrucessKING/CVE-2021-36749/blob/main/CVE-2021-36749.py

五、总结

Apache Druid 用户很多,而此次相关漏洞细节及 EXP 已在互联网公开,建议客户尽快自查修复。在官方发布更新通报后,对于尚未安装相关补丁的受影响用户,被活跃的黑客团伙攻击概率也相对较大。建议广大用户及时安装软件系统补丁,预防黑客利用相关漏洞进行攻击,避免企业受到严重损失。




觉得文章还不错?,点我收藏



本站内容均来自网络,若有侵权,请与我们联系:buaq.net[#]pm.me